const regex = /^((?!.*(anime|manga|hentai|sex|xxx)).*)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!.*(anime|manga|hentai|sex|xxx)).*)$', 'gmi')
const str = `This sentence contains anime
dsakdask Manga sakdklsa
sadlksadlk Hentai sklsdakl
Lots and lots of sex stuff
This sentence should pass
xxx movies sdkjsadk
hello world. this also should pass`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}