$re = '/^((?!.*(anime|manga|hentai|sex|xxx)).*)$/mi';
$str = 'This sentence contains anime
dsakdask Manga sakdklsa
sadlksadlk Hentai sklsdakl
Lots and lots of sex stuff
This sentence should pass
xxx movies sdkjsadk
hello world. this also should pass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);