#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<([a-z]+)([^>]*[^\/])?>(?![\s\S]*<\/\1)"
Local $sString = "<div>xyz 123 <rd> </div>" & @CRLF & _
"sample text <abc>" & @CRLF & _
"Text <input type="text"/> new value <bla>`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")