$re = '/<([a-z]+)([^>]*[^\/])?>(?![\s\S]*<\/\1)/i';
$str = '<div>xyz 123 <rd> </div>
sample text <abc>
Text <input type="text"/> new value <bla>`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);