using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z]+)([^>]*[^\/])?>(?![\s\S]*<\/\1)";
string input = @"<div>xyz 123 <rd> </div>
sample text <abc>
Text <input type=""text""/> new value <bla>`";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}