re = /<([a-z]+)([^>]*[^\/])?>(?![\s\S]*<\/\1)/i
str = '<div>xyz 123 <rd> </div>
sample text <abc>
Text <input type="text"/> new value <bla>`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end