#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div[^>]*>\s?(.*?)\s?<\/div>"
Local $sString = "<div class="thumbnail label_c_hd">HD</div>" & @CRLF & _
"" & @CRLF & _
"<div class="thumbnail label_c">" & @CRLF & _
"1 / 3 FOR GROUP" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>1 / 3 FOR GROUPS</div>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")