re = /<div[^>]*>\s?(.*?)\s?<\/div>/
str = '<div class="thumbnail label_c_hd">HD</div>
<div class="thumbnail label_c">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end