// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<div[^>]*>\s?(.*?)\s?<\/div>").unwrap();
let string = "<div class=\"thumbnail label_c_hd\">HD</div>
<div class=\"thumbnail label_c\">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS</div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}