const regex = /<div[^>]*>\s?(.*?)\s?<\/div>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div[^>]*>\\s?(.*?)\\s?<\\\/div>', 'g')
const str = `<div class="thumbnail label_c_hd">HD</div>
<div class="thumbnail label_c">
1 / 3 FOR GROUP
</div>
<div>1 / 3 FOR GROUPS</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}