#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@Leader_([\w]+)\s*(.*?)[[:punct:]]"
Local $sString = "Loreim ipsum lorem ipsum @Leader_abcXyz! loreim ipsum loreim ipsum @Leader_xyzAbc! loreim ipsum lorem ipsul @Leader_jklMno oremipsuim!" & @CRLF & _
"" & @CRLF & _
"@Leader_jehjrbs_nebw Can you file this for me?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")