using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@Leader_([\w]+)\s*(.*?)[[:punct:]]";
string input = @"Loreim ipsum lorem ipsum @Leader_abcXyz! loreim ipsum loreim ipsum @Leader_xyzAbc! loreim ipsum lorem ipsul @Leader_jklMno oremipsuim!
@Leader_jehjrbs_nebw Can you file this for me?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}