package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@Leader_([\w]+)\s*(.*?)[[:punct:]]`)
var str = `Loreim ipsum lorem ipsum @Leader_abcXyz! loreim ipsum loreim ipsum @Leader_xyzAbc! loreim ipsum lorem ipsul @Leader_jklMno oremipsuim!
@Leader_jehjrbs_nebw Can you file this for me?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}