$re = '/@Leader_([\w]+)\s*(.*?)[[:punct:]]/';
$str = 'Loreim ipsum lorem ipsum @Leader_abcXyz! loreim ipsum loreim ipsum @Leader_xyzAbc! loreim ipsum lorem ipsul @Leader_jklMno oremipsuim!
@Leader_jehjrbs_nebw Can you file this for me?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);