#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\t*)for\b(?=.*\bin\b.*?:)"
Local $sString = "for i in iterations:" & @CRLF & _
" pass"
Local $sSubst = "$1<color>for</color>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)