const regex = new RegExp('^(\\t*)for\\b(?=.*\\bin\\b.*?:)', 'g')
const str = `for i in iterations:
pass`;
const subst = `$1<color>for</color>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);