use strict;
my $str = 'for i in iterations:
pass';
my $regex = qr/^(\t*)for\b(?=.*\bin\b.*?:)/p;
my $subst = '$1<color>for</color>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";