$re = '/^(\t*)for\b(?=.*\bin\b.*?:)/';
$str = 'for i in iterations:
pass';
$subst = "$1<color>for</color>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;