#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<script.*src.*edge.*<\/script>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
" <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="IE=Edge"/>" & @CRLF & _
" <title>Untitled</title>" & @CRLF & _
"<!--Adobe Edge Runtime-->" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="IE=Edge">" & @CRLF & _
" <script src="//ad.adverticum.net/scripts/goa-helper.js"></script>" & @CRLF & _
" <script type="text/javascript" charset="utf-8" src="http://animate.adobe.com/runtime/5.0.0/edge.5.0.0.min.js"></script>" & @CRLF & _
" <style>" & @CRLF & _
" .edgeLoad-EDGE-20744748 { visibility:hidden; }" & @CRLF & _
" </style>" & @CRLF & _
"<script>" & @CRLF & _
" AdobeEdge.loadComposition('MM_Gyor_Huawei_1112-1114_HTML5_720x250', 'EDGE-20744748', {" & @CRLF & _
" scaleToFit: "none"," & @CRLF & _
" centerStage: "both"," & @CRLF & _
" minW: "0"," & @CRLF & _
" maxW: "undefined"," & @CRLF & _
" width: "720px"," & @CRLF & _
" height: "250px"" & @CRLF & _
"}, {"dom":{}}, {"dom":{}});" & @CRLF & _
"</script>" & @CRLF & _
"<!--Adobe Edge Runtime End-->" & @CRLF & _
"" & @CRLF & _
"</head>" & @CRLF & _
"<body style="margin:0;padding:0;">" & @CRLF & _
" <div id="Stage" class="EDGE-20744748"></div>" & @CRLF & _
" " & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")