use strict;
my $str = '<!DOCTYPE html>
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge"/>
<title>Untitled</title>
<!--Adobe Edge Runtime-->
<meta http-equiv="X-UA-Compatible" content="IE=Edge">
<script src="//ad.adverticum.net/scripts/goa-helper.js"></script>
<script type="text/javascript" charset="utf-8" src="http://animate.adobe.com/runtime/5.0.0/edge.5.0.0.min.js"></script>
<style>
.edgeLoad-EDGE-20744748 { visibility:hidden; }
</style>
<script>
AdobeEdge.loadComposition(\'MM_Gyor_Huawei_1112-1114_HTML5_720x250\', \'EDGE-20744748\', {
scaleToFit: "none",
centerStage: "both",
minW: "0",
maxW: "undefined",
width: "720px",
height: "250px"
}, {"dom":{}}, {"dom":{}});
</script>
<!--Adobe Edge Runtime End-->
</head>
<body style="margin:0;padding:0;">
<div id="Stage" class="EDGE-20744748"></div>
</body>
</html>';
my $regex = qr/<script.*src.*edge.*<\/script>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}