# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script.*src.*edge.*<\/script>"
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
"<head>\n"
" <meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\"/>\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"IE=Edge\"/>\n"
" <title>Untitled</title>\n"
"<!--Adobe Edge Runtime-->\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"IE=Edge\">\n"
" <script src=\"//ad.adverticum.net/scripts/goa-helper.js\"></script>\n"
" <script type=\"text/javascript\" charset=\"utf-8\" src=\"http://animate.adobe.com/runtime/5.0.0/edge.5.0.0.min.js\"></script>\n"
" <style>\n"
" .edgeLoad-EDGE-20744748 { visibility:hidden; }\n"
" </style>\n"
"<script>\n"
" AdobeEdge.loadComposition('MM_Gyor_Huawei_1112-1114_HTML5_720x250', 'EDGE-20744748', {\n"
" scaleToFit: \"none\",\n"
" centerStage: \"both\",\n"
" minW: \"0\",\n"
" maxW: \"undefined\",\n"
" width: \"720px\",\n"
" height: \"250px\"\n"
"}, {\"dom\":{}}, {\"dom\":{}});\n"
"</script>\n"
"<!--Adobe Edge Runtime End-->\n\n"
"</head>\n"
"<body style=\"margin:0;padding:0;\">\n"
" <div id=\"Stage\" class=\"EDGE-20744748\"></div>\n"
" \n"
"</body>\n"
"</html>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.