$re = '/<script.*src.*edge.*<\/script>/';
$str = '<!DOCTYPE html>
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta http-equiv="X-UA-Compatible" content="IE=Edge"/>
<title>Untitled</title>
<!--Adobe Edge Runtime-->
<meta http-equiv="X-UA-Compatible" content="IE=Edge">
<script src="//ad.adverticum.net/scripts/goa-helper.js"></script>
<script type="text/javascript" charset="utf-8" src="http://animate.adobe.com/runtime/5.0.0/edge.5.0.0.min.js"></script>
<style>
.edgeLoad-EDGE-20744748 { visibility:hidden; }
</style>
<script>
AdobeEdge.loadComposition(\'MM_Gyor_Huawei_1112-1114_HTML5_720x250\', \'EDGE-20744748\', {
scaleToFit: "none",
centerStage: "both",
minW: "0",
maxW: "undefined",
width: "720px",
height: "250px"
}, {"dom":{}}, {"dom":{}});
</script>
<!--Adobe Edge Runtime End-->
</head>
<body style="margin:0;padding:0;">
<div id="Stage" class="EDGE-20744748"></div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);