using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+)((?:,\s*[a-z]+)*)\s+(and|or)\s+([a-z]+)";
string input = @"white and blue ... white, and blue ... dark, green, gray and silver";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}