$re = '/([a-z]+)((?:,\s*[a-z]+)*)\s+(and|or)\s+([a-z]+)/';
$str = 'white and blue ... white, and blue ... dark, green, gray and silver';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);