package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z]+)((?:,\s*[a-z]+)*)\s+(and|or)\s+([a-z]+)`)
var str = `white and blue ... white, and blue ... dark, green, gray and silver`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}