// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-z]+)((?:,\s*[a-z]+)*)\s+(and|or)\s+([a-z]+)").unwrap();
let string = "white and blue ... white, and blue ... dark, green, gray and silver";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}