using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,?[a-zA-Z][a-zA-Z0-9]*,?)";
string input = @"red, 1 ,yellow, 4, red1, 1yellow yellow
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}