package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(,?[a-zA-Z][a-zA-Z0-9]*,?)`)
var str = `red, 1 ,yellow, 4, red1, 1yellow yellow
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}