re = /(,?[a-zA-Z][a-zA-Z0-9]*,?)/
str = 'red, 1 ,yellow, 4, red1, 1yellow yellow
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end