package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(.*?_c.*?)(\..*)`)
var str = `bodaclick-septiembre18-1-23698_c1399.jpg`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}