use strict;
my $str = 'bodaclick-septiembre18-1-23698_c1399.jpg';
my $regex = qr/(.*)(.*?_c.*?)(\..*)/p;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";