$re = '/(.*)(.*?_c.*?)(\..*)/';
$str = 'bodaclick-septiembre18-1-23698_c1399.jpg';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;