re = /(.*)(.*?_c.*?)(\..*)/
str = 'bodaclick-septiembre18-1-23698_c1399.jpg'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result