using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-TV-Z]\d{2}(\.[A-Z\d]{0,4})?$";
string input = @"A18.32
A28.2
A04.0
A18.R252
A18
A18.52
R18
R18.
A184.32
U18
111.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}