import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-TV-Z]\\d{2}(\\.[A-Z\\d]{0,4})?$";
final String string = "A18.32\n"
+ "A28.2\n"
+ "A04.0\n"
+ "A18.R252\n"
+ "A18\n"
+ "A18.52\n"
+ "R18\n"
+ "R18.\n"
+ "A184.32\n"
+ "U18\n"
+ "111.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}