// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-TV-Z]\d{2}(\.[A-Z\d]{0,4})?$").unwrap();
let string = "A18.32
A28.2
A04.0
A18.R252
A18
A18.52
R18
R18.
A184.32
U18
111.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}