$re = '/^[A-TV-Z]\d{2}(\.[A-Z\d]{0,4})?$/m';
$str = 'A18.32
A28.2
A04.0
A18.R252
A18
A18.52
R18
R18.
A184.32
U18
111.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);