import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>(.+)\\[…\\]<\\/p>";
final String string = "<p>Am 15. Februar 2016 erschein Rage of Bahamut: Genesis Exklusive bei Amazon in einer limitierten Version inklusive Soundtrack im Mediabook auf DVD und Blu-ray, die Einzel Veröffentlichung in zwei Volumes folgt dann im April und Mai. Wer den Anime gern sehen will, hat jetzt bei Clipfish die Chance. Dort gibt es alle zwölf Folgen im […]</p>\n"
+ "<p>Der Beitrag <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/rage-of-bahamut-genesis-neu-bei-clipfish/\">Rage of Bahamut: Genesis neu bei Clipfish</a> erschien zuerst auf <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/\">AnimeNachrichten - Aktuelle Nachrichten rund um Anime, Manga, Games und das TV Programm</a>.</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}