use strict;
my $str = '<p>Am 15. Februar 2016 erschein Rage of Bahamut: Genesis Exklusive bei Amazon in einer limitierten Version inklusive Soundtrack im Mediabook auf DVD und Blu-ray, die Einzel Veröffentlichung in zwei Volumes folgt dann im April und Mai. Wer den Anime gern sehen will, hat jetzt bei Clipfish die Chance. Dort gibt es alle zwölf Folgen im […]</p>
<p>Der Beitrag <a rel="nofollow" href="https://www.animenachrichten.de/rage-of-bahamut-genesis-neu-bei-clipfish/">Rage of Bahamut: Genesis neu bei Clipfish</a> erschien zuerst auf <a rel="nofollow" href="https://www.animenachrichten.de/">AnimeNachrichten - Aktuelle Nachrichten rund um Anime, Manga, Games und das TV Programm</a>.</p>';
my $regex = qr/<p>(.+)\[…\]<\/p>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}