import re
regex = re.compile(r"<p>(.+)\[…\]<\/p>")
test_str = ("<p>Am 15. Februar 2016 erschein Rage of Bahamut: Genesis Exklusive bei Amazon in einer limitierten Version inklusive Soundtrack im Mediabook auf DVD und Blu-ray, die Einzel Veröffentlichung in zwei Volumes folgt dann im April und Mai. Wer den Anime gern sehen will, hat jetzt bei Clipfish die Chance. Dort gibt es alle zwölf Folgen im […]</p>\n"
"<p>Der Beitrag <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/rage-of-bahamut-genesis-neu-bei-clipfish/\">Rage of Bahamut: Genesis neu bei Clipfish</a> erschien zuerst auf <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/\">AnimeNachrichten - Aktuelle Nachrichten rund um Anime, Manga, Games und das TV Programm</a>.</p>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")