# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.{1,20}$)(?=.*。)(?!.*,)([^。]*)。/$1/gm;t' <<< "<h1>这是一个测试。<h1>
这是一个测试,这是一个测试而已,希望去掉不需要的。
测试。
这是一个测试,这是一个测试而已,希望去掉不需要的第二行。
这是一行非常长的文字但是句号不需要被移除。"