import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{1,20}$)(?=.*。)(?!.*,)([^。]*)。";
final String string = "<h1>这是一个测试。<h1>\n"
+ "这是一个测试,这是一个测试而已,希望去掉不需要的。\n\n"
+ "测试。\n"
+ "这是一个测试,这是一个测试而已,希望去掉不需要的第二行。\n"
+ "这是一行非常长的文字但是句号不需要被移除。";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}