import re
regex = re.compile(r"^(?=.{1,20}$)(?=.*。)(?!.*,)([^。]*)。", flags=re.MULTILINE)
test_str = ("<h1>这是一个测试。<h1>\n"
"这是一个测试,这是一个测试而已,希望去掉不需要的。\n\n"
"测试。\n"
"这是一个测试,这是一个测试而已,希望去掉不需要的第二行。\n"
"这是一行非常长的文字但是句号不需要被移除。")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)