re = /^(?=.{1,20}$)(?=.*。)(?!.*,)([^。]*)。/m
str = '<h1>这是一个测试。<h1>
这是一个测试,这是一个测试而已,希望去掉不需要的。
测试。
这是一个测试,这是一个测试而已,希望去掉不需要的第二行。
这是一行非常长的文字但是句号不需要被移除。'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result