#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)^[A-Za-z0-9=.,:\s-]+$"
Local $sString = "Host: x-sgdo40.serverip.co" & @CRLF & _
"Username: fastssh.com-test" & @CRLF & _
"Password: test" & @CRLF & _
"Port: 443" & @CRLF & _
"Info: Date Expired : 10-November-2016"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")