re = /^[A-Za-z0-9=.,:\s-]+$/
str = 'Host: x-sgdo40.serverip.co
Username: fastssh.com-test
Password: test
Port: 443
Info: Date Expired : 10-November-2016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end