import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9=.,:\\s-]+$";
final String string = "Host: x-sgdo40.serverip.co\n"
+ "Username: fastssh.com-test\n"
+ "Password: test\n"
+ "Port: 443\n"
+ "Info: Date Expired : 10-November-2016";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}