import re
regex = re.compile(r"^[A-Za-z0-9=.,:\s-]+$", flags=re.UNICODE)
test_str = ("Host: x-sgdo40.serverip.co\n"
"Username: fastssh.com-test\n"
"Password: test\n"
"Port: 443\n"
"Info: Date Expired : 10-November-2016")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")