#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d*(.\d+)?$"
Local $sString = "1.2345" & @CRLF & _
"123.45" & @CRLF & _
"123." & @CRLF & _
".12345" & @CRLF & _
"0.1234" & @CRLF & _
"4.1234" & @CRLF & _
"4x1234" & @CRLF & _
"1-23455"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")