// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d*(.\d+)?$").unwrap();
let string = "1.2345
123.45
123.
.12345
0.1234
4.1234
4x1234
1-23455";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}